Never Settle

Zabbix 4.0升级至4.2

一、关闭服务,备份数据库

Systemctl stop zabbix-server,然后备份数据库,备份原有配置文件等

二、添加 Zabbix 软件仓库,升级软件包

rpm -Uvh https://repo.zabbix.com/zabbix/4.2/rhel/7/x86_64/zabbix-release-4.2-1.el7.noarch.rpm
yum upgrade zabbix-server-mysql zabbix-web-mysql

三、重新启动Zabbix服务

systemctl start zabbix-server

此时log可能会报错:

《Zabbix 4.0升级至4.2》

错误一:required mandatory version: 04020000

错误二:[Z3005] query failed: [1060] Duplicate column name ‘error_handler’ [alter table item_preproc add error_handler integer default ‘0’ not null]

错误一解决办法:

进入数据库:
mysql> show databases;
mysql> use zabbix;
mysql> update dbversion set mandatory= 04020000;

错误二解决办法:

在数据库 item_preproc 表中,把 error_handler 列重命名或者删除,zabbix会自动升级重建。

《Zabbix 4.0升级至4.2》

四、修复升级Zabbix 4.2版本图表字体空白

升级到4.2后,字体库文件夹由 /usr/share/zabbix/fonts/ 更改为/usr/share/zabbix/assets/fonts,同时在 /usr/share/zabbix/include/defines.inc.php 重新指定字体文件,之后图表就能正常显示文字了。

《Zabbix 4.0升级至4.2》

五、修复Web页面权限

此时进入Web界面会提示:Insufficient file system permissions. Assets cache directory is not writable.

解决办法: sudo chmod -R 777 /usr/share/zabbix/assets

点赞

发表评论

电子邮件地址不会被公开。 必填项已用*标注